Heiko Zimmermann
SAP-Berater, System Engineer und Entwickler.

Weblog

Ich betreibe meine Website mit dem Banshee PHP Framework. Dieses gilt als sehr sicher und wurde auch entsprechend auditiert. Darin eingebettet ist der CKEditor. Dieser verursacht gerade eine Sicherheitslücke in Drupal und sollte dringend aktualisiert werden. Das zugehörige Patch greift ab der Version 4.9.2.

In Banshee geht das Update seit Version 5.3 extrem einfach. Man wechselt in der Shell in das Verzeichnis extra und führt folgendes aus:

extra # ./download_ckeditor 4.9.2 
Downloading CKEditor version 4.9.2.
Installing CKEditor.
Cleaning up.

Damit ist die Aufgabe abgeschlossen.